Embedded Automation Forum  

Go Back   Embedded Automation Forum > mHome Products > mControl Application Notes > Using Security Systems with mControl
Forums FAQ Members List Calendar Search Today's Posts Mark Forums Read

Using Security Systems with mControl Tips and tricks on how to use security systems with mControl

Reply
 
Thread Tools Display Modes
  #1  
Old 10-25-2007, 07:52 PM
Ted Singh's Avatar
Ted Singh Ted Singh is offline
Senior Member
Site Admin
 
Join Date: Nov 2005
Posts: 1,108
Default HOW TO: Setup Honeywell Ademco systems

mControl supports the Honeywell ADEMCO VISTA-128BP and and VISTA-250BP security systems via the 4100SM Serial Interface Module.

The following things must be done to use your Ademco system within mControl:


1. Configure the Ademco system to properly use the 4100SM. Using your installer code, set the following parameters:
a) Enable 'System Events Notify': *05, enter 1 to view all zone faults/restores
b) Enable 'RS-232 Input (Home Automation)': *14, enter 1 for Home Automation Control (cannot use both serial printer and Home Automation)
c) Enable various event types: 1*70, enter 11111 to enable event log for alarm, check, bypass, open/close and system
d) Disable 'Pager': 2*30, enter 0 to disable Pager
2. Configure mControl to load the Ademco driver - follow instructions in the 'Using Honeywell ADEMCO VISTA Security Systems' section of the mControl v2 User Manual to adjust the XML to load and use of the Ademco driver.
IMPORTANT: If there are other adapters using the same serial COM port - for example, by default, the CM11A driver is loaded on COM1 - you may need to either change the port that the Ademco is on, or disable the other adatepr.
3. Add an Ademco device within mControl.

Once this is done, you will be able to view and control your Ademco system from within all of mControl's client interfaces.

Ted

We'd like to thank forum user 'dstarr' for his help on this topic.
Reply With Quote
  #2  
Old 05-20-2008, 03:44 PM
keith keith is offline
Junior Member
 
Join Date: May 2008
Posts: 2
Default

Hi - I have an older ADEMCO security system and the 4100SM is not compatible with it, however the following is recommended as an alternative:

http://www.alarmsuperstore.com/ademc...m/ciamodem.htm

Do you know if this modem will work with mcontrol?
Reply With Quote
  #3  
Old 05-20-2008, 05:15 PM
Ted Singh's Avatar
Ted Singh Ted Singh is offline
Senior Member
Site Admin
 
Join Date: Nov 2005
Posts: 1,108
Default

keith,

Which model do you have? In briefly reviewing this, it's not clear whether this is an alternative to the 4100SM.

Ted
Reply With Quote
  #4  
Old 05-20-2008, 06:12 PM
docbliny docbliny is offline
Member
 
Join Date: Mar 2008
Posts: 33
Default

Are there any plans to support the Vista ICM (over ethernet) which I happen to have?

//Tomi B.
Reply With Quote
  #5  
Old 05-20-2008, 08:01 PM
katrash katrash is offline
mControl Dev. Team
Site Admin
 
Join Date: Dec 2005
Location: Langley, BC, Canada
Posts: 568
Default

There is already a support for Ademco over ethernet connection. Setup this connection parameters using the automation service manager and test the ICM - it might be supported if it is compatible with the other models we support.
Reply With Quote
  #6  
Old 05-21-2008, 05:05 PM
keith keith is offline
Junior Member
 
Join Date: May 2008
Posts: 2
Default

Hi Ted - I believe I have a vista 20P or something similar.
Reply With Quote
  #7  
Old 05-21-2008, 05:16 PM
Ted Singh's Avatar
Ted Singh Ted Singh is offline
Senior Member
Site Admin
 
Join Date: Nov 2005
Posts: 1,108
Default

keith,

Just did a bit of research on this and, unfortunately, it doesn't look like our existing Ademco driver will work with the 20P through the CIA device. That's not to say that you won't be able to control it, but out of the box support using our existing 4100SM-based driver doesn't look like it will work.

It appears the best strategy might be to write another driver for the CIA device.

Ted
Reply With Quote
  #8  
Old 06-17-2008, 11:46 AM
chilump chilump is offline
Junior Member
 
Join Date: Mar 2008
Posts: 8
Default

Quote:
Originally Posted by keith View Post
Hi Ted - I believe I have a vista 20P or something similar.
Keith,

Were you able to get mcontrol working with your Vista 20p control panel? This is the system that ADT installs and I would like it to work with mControl.

If you got it to work what additional software did you need to get?

Any help would be greatly appreciated
Reply With Quote
  #9  
Old 06-24-2008, 03:02 PM
burnspc burnspc is offline
Junior Member
 
Join Date: May 2008
Posts: 11
Default Honeywell Ademco Vista

I am curious as well about ICM Vista ethernet module working with MControl and all Honeywell Ademco Vista alarm systems.

I am installing alarm system in the next couple of weeks depending on which system is compatible with MControl.

Thank you for any help!
Reply With Quote
  #10  
Old 09-22-2008, 04:20 PM
docbliny docbliny is offline
Member
 
Join Date: Mar 2008
Posts: 33
Default

Quote:
Originally Posted by Ted Singh View Post
keith,

Just did a bit of research on this and, unfortunately, it doesn't look like our existing Ademco driver will work with the 20P through the CIA device. That's not to say that you won't be able to control it, but out of the box support using our existing 4100SM-based driver doesn't look like it will work.

It appears the best strategy might be to write another driver for the CIA device.

Ted
Ted,

I put together a .NET component that receives data from the Vista ICM unit and you can send commands to it via normal HTTP GET requests. Would you have any interest in working together to get this wrapped in the mControl driver architecture so we can get support for the Ademco/Honeywell Vista ICM (Internet Connection Module)? This would allow users with a Vista 20P or similar to get mControl support.

If anyone else is interested in the source, send me a PM and I'll get you the link to the VS2008/C# source.

//Tomi B.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 01:03 PM.


Powered by vBulletin® Version 3.8.3
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.