PDA

View Full Version : Weird IR Behavior, Command Doesn't Work Twice


hadiesper
01-26-2011, 11:30 AM
Hey guys,

I am facing a very weird problem with my IR commands and I cannot even explain it so any help would be appreciated.

I used the USB UIRT to learn the IR codes for the windows MCE. I only learnt "LEFT" and "RIGHT". and when I tested them they worked perfectly fine. But they do not work if 1 button is pressed twice in a row.

for example:
pressing right works... pressing right again doesnt work!.. pressing right again after 5 minutes doesnt work... pressing left works.. pressing right works.. pressing right again doesnt work!!

Now thats just weird.. what is going on!? anyone?

hadiesper
01-26-2011, 11:36 AM
UPDATE: it is not about right and left directions.. any IR command sent front he USB UIRT cannot be executed twice in a row.. to execute a command the second time I should send any IR command command (LEFT, UP, PLAY , VOLUMEUP... even any command from the MCe remote(not from the USB-UIRT)

ezzye
01-26-2011, 02:03 PM
No worries, there is a setting in the registry called debounce. If you set this to
0 it will take care of it.


HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\H idIr\Remotes\745a17a0-74d3-11d0-b6fe-00a0c90f57da

hadiesper
01-27-2011, 10:57 PM
hmmm... and I was wondering what debounce does.. thanks for the help.. that worked :)